Follow
Workfront Software Requirements

Workfront requires the use of some basic software components. The supported versions of those components are as follows:

Web browser: Workfront officially supports the current browser version and one previous version for Chrome, Firefox, and Safari. Internet Explorer 11 is also supported.

In addition, Workfront will support any previous version that constitutes at least five percent of total Workfront traffic.

IMPORTANT: Microsoft discontinued all support (including severe security vulnerabilities) for IE 7 and IE 8 on January 12, 2016. In addition, IE 9 and IE 10 have also been discontinued in most circumstances. Microsoft’s rationale behind this decision was based on the substantial security concerns with the architecture of these browsers that could severely impact users.

If you are using Internet Explorer 9, a new banner appears. To ensure your browser is up to date click here for the latest versions. 

For more information, see the Internet Explorer Support Lifecycle FAQ on the Microsoft Support site.

Adobe Flash Plugin: Version 10.1 or greater. Proofing users must have version 11.1 or greater.

The Adobe Flash Plugin is required in order for certain areas of the Workfront interface to function (such as the Resource Grid, Resource Budget Manager, Capacity Planner, and the Legacy Gantt Chart).

IMPORTANT: Most browsers are configured by default to block the use of the Adobe Flash Plugin. To ensure that you can use all areas of the Workfront application, you must configure your browser to allow the Adobe Flash Plugin to be used on your Workfront site.