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When Logging In, User Is Receiving This Error: Let's try that again. The following fields are invalid: emailAddr cannot be null.

Login Problem 

  1.  User navigates to their Workfront URL  https://customerdomain.my.workfront.com
  2.  They are redirected to the SAML login portal. This is the correct location.
  3.  They enter their SAML username and password.
  4.  They are redirected back to Workfront.
  5.  They receive this error: Let's try that again. The following fields are invalid: emailAddr cannot be null.

Cause

The Map User Attributes area has been configured incorrectly.

For more information about mapping user attributes for SAML 2.0, see "Configuring Workfront with SAML 2.0."

Resolution

This is caused by an incorrect item in the Map User Attributes area of the SAML 2.0 configuration. This area has an attribute mapping for the email address with an incorrect directory attribute or default value. Remove this from the Attribute Mapping and save the new setup.

NOTE This error can be any of the Workfront User Attributes, it is not specific to emailAddr. It could be name cannot be null, or jobRole cannot be null, etc.