Follow
API script broke since upgrading the Access Levels.

Resolution

Running the API returns the following Error: The security model type for this access level needs to match the security model type for your customer.

Cause 

After upgrading Access Levels, new ones are created and therefore each access receives a new ID.

Fix

Correct the API to use the new Access Levels ID. Try creating a new view from the access level screen and include the ID to find them.